Znaleziono 9 wyników

autor: ronnie91
8 sie 2016, 14:45
Forum: Problemy
Temat: BMP280
Odpowiedzi: 9
Odsłony: 4017

Re: BMP280

Problem rozwiazany. byly bledy w bibliotece BMP280. pozdrawiam
autor: ronnie91
4 sie 2016, 13:04
Forum: Problemy
Temat: BMP280
Odpowiedzi: 9
Odsłony: 4017

Re: BMP280

Czujnik zasilam z 3.3 V Co do tego ze przy zaprogramowaniu mam rozne wartosci cisnienia tzn. raz okolo 720 hpa a raz 976, to widze ze nie zawsze on sie poprawnie konfiguruje. bo te 720 hPa to widze z noty ze jest reset state i wogole dzialki i cisnienie sie nie zmianiaja, a jak jest 950 to dzialki s...
autor: ronnie91
4 sie 2016, 12:09
Forum: Problemy
Temat: BMP280
Odpowiedzi: 9
Odsłony: 4017

Re: BMP280

uzywam stm32f407 i crossworks
autor: ronnie91
4 sie 2016, 11:20
Forum: Problemy
Temat: BMP280
Odpowiedzi: 9
Odsłony: 4017

Re: BMP280

Ale właśnie w nocie bmp280 nic nie ma o cisnieniu w odniesieniu do poziomu morza. A sprawdziłem w bmp180 jest taki podrozdział. Wiec chyba nie to. Poza tym czemu tak skacze cisnienienie po wgraniu do procka?
autor: ronnie91
4 sie 2016, 10:08
Forum: Problemy
Temat: BMP280
Odpowiedzi: 9
Odsłony: 4017

BMP280

Cześć, mam problem z działaniem czujnika ciśnienia BMP280. Komunikuje się z nim poprzez magistrale I2C. Dodam że używam biblioteki wykonanej przez producenta czujnika. Komunikuje się z nim, odczytuje poprawnie device id, szczytuje współczynniki które są w pamięci czujnika, tylko ze pokazuje mi niepr...
autor: ronnie91
18 lip 2016, 10:05
Forum: Software
Temat: Problem z CrossWorks
Odpowiedzi: 2
Odsłony: 5376

Re: Problem z CrossWorks

Zrobiłem tak jak napisałeś i niestety nadal nie działa. Dodam, że jak jeszcze działał program to ściągnąłem nowszą wersję crossworksa i przez jakiś czas działały oba. W tej chwili nowsza wersja działa, a starsza nie. Muszę używać jednocześnie obu, bo na starszym mam napisany program, który nie kompi...
autor: ronnie91
15 lip 2016, 14:51
Forum: Software
Temat: Problem z CrossWorks
Odpowiedzi: 2
Odsłony: 5376

Problem z CrossWorks

Do programowania mikrokontrolerów używam oprogramowania CrossWorks i przez jakiś czas normalnie działał. Jednak w pewnym momencie chciałem go uruchomić i pojawił się komunikat "Unrecoverable failure Internal error detected" i nie mogę go uruchomić. Przeinstalowywałem go już kilka razy i usuwałem prz...
autor: ronnie91
17 lut 2016, 10:05
Forum: Problemy
Temat: W5200 ethernet shield
Odpowiedzi: 1
Odsłony: 1044

Re: W5200 ethernet shield

Dobra już działa. Natomiast mam inny problem. Jak łącze się z terminalem po raz pierwszy po przesłaniu programu do mikrokontrolera, to zawsze się łączy, mogę przesyłać dane. Jak teraz wyłączę terminal i ponownie w łącze w przeciągu kilku sekund to też działa, ale jak poczekam kilka minut to nie chce...
autor: ronnie91
9 lut 2016, 13:37
Forum: Problemy
Temat: W5200 ethernet shield
Odpowiedzi: 1
Odsłony: 1044

W5200 ethernet shield

Cześć, Robie ethernet na stm32. Zrobiłem już TCP server i wszystko działa. Moduł jako server, komputer jako client. Na terminalu odbieram dane wysyłane przez moduł. Teraz chce zrobić clienta na module a serverem będzie komputer. Korzystam z bibliotek w5200. W application note jest napisane, że tcp l...

Strony partnerskie: