Znaleziono 28 wyników

autor: Dudinr1
27 sie 2014, 22:20
Forum: Jak to zrobić?
Temat: [Rozwiązany]Ardudriod, Arduino Leo-zapisywanie wartości PWM
Odpowiedzi: 6
Odsłony: 5811

Re: Ardudriod, Arduino Leo - zapisywanie wartości PWM

Dobra port szeregowy na usb i moduł btm-222 przyszły kurierem. Podejrzałem w jakiej formie aplikacja wysyła dane. * prawdopodobnie wskazuje na początek komendy, a # na jej koniec Klikając przyciski odpowiadające poszczególnym pinom wysyła: *10|"numer pinu"|"stan pinu, przyjmujący wartość 2 lub 3, kt...
autor: Dudinr1
20 sie 2014, 00:00
Forum: Jak to zrobić?
Temat: [Rozwiązany]Ardudriod, Arduino Leo-zapisywanie wartości PWM
Odpowiedzi: 6
Odsłony: 5811

Re: Ardudriod, Arduino Leo - zapisywanie wartości PWM

Nie do końca miałem to na myśli ale zawsze jakiś pomysł. Sama aplikacja będzie odpalana rzadko w samochodzie, no chyba że na początku dopóki nie minie mi faza na zabawę i chwalenie się znajomym co zrobiłem:) Ale na serio. Chodziło mi o funkcję/biblioekę/komende/procedurę, która sczyta aktualne warto...
autor: Dudinr1
19 sie 2014, 17:38
Forum: Jak to zrobić?
Temat: [Rozwiązany]Ardudriod, Arduino Leo-zapisywanie wartości PWM
Odpowiedzi: 6
Odsłony: 5811

Re: Ardudriod, Arduino Leo - zapisywanie wartości PWM

Dziś mam nadzieję przyjdzie do mnie port szerwgowy pod usb, do którego podłączę BT i sobie podejrzę przez putty co apka dokładnie wysyła. Szczególnie w jakiej formie wysyła wartość pola tekstowego w apce. Już widzę ten kod co po wpisaniu "disco" i wysłaniu do arduino migocze mi światłami w samochodz...
autor: Dudinr1
15 sie 2014, 01:54
Forum: Jak to zrobić?
Temat: [Rozwiązany]Ardudriod, Arduino Leo-zapisywanie wartości PWM
Odpowiedzi: 6
Odsłony: 5811

[Rozwiązany]Ardudriod, Arduino Leo-zapisywanie wartości PWM

Edytuję posta podając rozwiązanie w zwięzły sposób. Wątek pozostawiam bez zmian. Skrócony opis problemu: Przechwycenie wartości pinów PWM i zapis do pamięci EEPROM, a następnie automatyczne ich wczytanie przy ponownym uruchomieniu/podciągnięciu zasilania do Arduino. Arduino wykorzystuję do sterowani...
autor: Dudinr1
17 lut 2014, 23:16
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Sprawdzałem miernikiem każdy element i każdą nóżkę. Co prawda gniazdo jest lutowane po przeciwnej stronie ścieżek lecz wcześniej był moment, w którym temperaturę pokazywało jednak rozdzielczość wynosiła od 25 do 200 stopni gdzie grot grzał się do czerwoności, co odwróciło moją uwagę od gniazda. Taki...
autor: Dudinr1
17 lut 2014, 18:13
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Szczęśliwie dotarliśmy do końca sprawy. Problemem były, jak to odpisał serwis AVT: "uszkodzone były przelotki pod złączem ARK do termopary". Dziękuję wszystkim za wsparcie i porady, jak się okazuje nie można niczego zakładać, nawet tego że fabryczna płytka drukowana jest ok, ja to niestety założyłem...
autor: Dudinr1
3 lut 2014, 23:58
Forum: Problemy
Temat: Arduino Leonardo i BTM-222 - lagi
Odpowiedzi: 0
Odsłony: 1238

Arduino Leonardo i BTM-222 - lagi

Hej wszystkim, nabyłem moduł BTM-222 z zamiarem sterowania arduino Leonardo za pośrednictwem BT. Z arduino w wersji leonardo są problemy z wykorzystaniem pinów TX i RX do komunikacji z modułem, ten problem udało mi się rozwiązać, a całość opisałem w "monologu" pod linkiem: http://www.elektroda.pl/rt...
autor: Dudinr1
28 sty 2014, 13:17
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Chciałem zaznaczyć, że zakupiłem zestaw do złożenia z zaprogramowanym uC. Czy w związku z tym Fusebit'y nie powinny być domyślnie dobrze ustawione? Zbych72 rozwiń proszę myśl, każdy trop sprawdzę. Fusebity umiem ustawiać (znalazłem instrukcję w internecie), ciekawi mnie czy Ty miałeś taki przypadek,...
autor: Dudinr1
27 sty 2014, 19:04
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Nie Edytuję posta, aby wyskoczyła informacja o nowym wpisie. Wylutowałem Atmegę8, wlutowałem podstawkę i umieściłem w niej nowy uC. Wskazania temperatury ciągle się nie zmieniają. Odczyt temperatury jest podciągnięty do 23 nóżki uC, jest to wejście ADC0, w momencie gdy przykładam do pinu sonde miern...
autor: Dudinr1
22 sty 2014, 13:22
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Tomku, spoko:) Czytałem sporo na temat uziemienia lutownicy i temat jest dość rozbudowany, a samych opinii też sporo. Wczoraj w nocy wylutowalem ostrożnie Atmege. Niestety całość robię na raty i było na tyle późno, że wlutowanie podstawki zostawiam na dziś wieczór, dam znać. Zaprogramowany uC mam z ...
autor: Dudinr1
20 sty 2014, 01:01
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Lutuję stacją taką jak pokazałem parę postów wyżej, to z drucikiem na transformatorową to był żart:) Wstrzymam się chwilę z naprawą aż zdobędę/dostanę program na Atmegę do tej stacji. Wgram go na nietkniętą tą lutownicą Atmegę i zainstaluję ją poprzez podstawkę. Zawsze przed dotknięciem się do lutow...
autor: Dudinr1
19 sty 2014, 19:17
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Moje samodzielne myślenie skłoniło mnie do zadania tego pytania ale dzięki za sugestię oraz odpowiedź. Jest ciągłość obwodu między grotem, a uziemieniem we wtyczce. Instalacja również ok. Napiszę za chwilę do sklepu AVT czy nie mieli informacji o problemach ze stacją w ostatnim czasie, może to coś d...
autor: Dudinr1
19 sty 2014, 13:36
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Mathef: Tak kupiłem od razu zaprogramowany. Dałem bez podstawki ponieważ przeczytałem, że jeśli nie planuje się wymiany uC to lepiej wlutować bezpośrednio. Jednym z argumentów była lepsza wymiana ciepła. Tomasz.B: Miedziany drucik na transformatorową i lutujemy smd:) Ale na serio, posiadam małą "st...
autor: Dudinr1
18 sty 2014, 17:48
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Zdjęcia mogą mieć maksymalnie 820px szerokości, za chwilę dodam linki i edytuje posta edit: Mam nadzieję, że jakość wystarczająca. Ciężko osiągnąć mi lepsza jakość moim aparatem, jeśli jednak będzie za niska pożyczę aparat i postaram się o lepsze zdjęcia. Na marginesie, czy zdarza się wam podczas lu...
autor: Dudinr1
17 sty 2014, 00:06
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Na lewo od c12 na ostatnim zdjęciu jest rezystor 000 wlutowany z drugiej strony, jest to smd a miejsca są jak na przewlekany stąd taki wygląd całości nie jest to błąd. luty na scalaku są ładne, może zdjęcie tego nie oddaje, ale jakby coś nie łączyło to mała szansa aby wyświetlacz tak stabilnie dział...
autor: Dudinr1
16 sty 2014, 02:08
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Zakupiłem nowy zestaw. Zlutowałem go bardzo dokładnie, na prawdę jestem zadowolony. Oczyściłem płytkę. Sprawdziłem napięcia: M9V -9,11V P9V 8,93V VCC 4,98V Po zwarciu GRZ i ZCD: 10,9V DC wcześniej pisałeś, że powinien być AC jednak miernik nic nie pokazuje KU z mierzenia rezystorów wyszło 101,2 Po w...
autor: Dudinr1
13 lis 2013, 18:44
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Doczytam/Douczę się jak identyfikować kondensatory smd (czy tylko po barwie i rozmiarze?) i poszukam wśród moich elektro odzyskanych elementów zamienników, ponieważ w paczce jaką ostatnio zamówiłem nie ma tych pojemności. Podeślę jeszcze po powrocie z pracy dokładne zdjęcia obu stron płytki sterowni...
autor: Dudinr1
12 lis 2013, 22:50
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Transformator kupiłem nowy, dokładnie taki jaki był zalecany na blogu. Tak władowałem w obudowę po zasilaczu ATX, jak był napisane pasuje idealnie i ja się z tym nie sprzeczam:) jest 9,4V, to nie jest zły objaw? Myślałem, że powinno być 12V? Kupiłem zestaw elementów smd i będę dziś próbował badać pł...
autor: Dudinr1
9 lis 2013, 17:10
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Po zwarciu GRZ i ZCD w tym czasie na wyjściu grzałki (J2 na schemacie) odnotowałem 9,4 V. Wylutowałem rezystory R4(1001kohm) i R5(9,99kohm) Ze wzoru KU=1+R4/R5 => KU=101,2 Takie ustawiłem i rozpocząłem autokalibracje, która trwała F1 około 30 sekund, a faza 2 około minuty. Na marginesie, nie odpisyw...
autor: Dudinr1
6 lis 2013, 13:24
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

W instrukcji napisano: Proces regulacji trwa kilkanaście minut i jest wykonywany tylko jednorazowo w momencie pierwszego podłączenia lub zmiany lutownicy... U mnie ten proces trwa około minuty, czy to może wskazywać z czym jest problem? Po powrocie do domu zresetuje nastawy przytrzymując wszystkie g...
autor: Dudinr1
5 lis 2013, 12:32
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Poza sprawdzeniem programu i wymianą op07 zrobiłem już sporo aby rozwiązać problem, jednak ciągle nic.
Skończy się na kupnie nowego KIT'u i złożeniu jeszcze raz;)

Wcześniej o tym nie myślałem ale czy ktoś spotkał się z uszkodzoną termoparą w grzałce?
autor: Dudinr1
29 paź 2013, 16:12
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

OP07 będę musiał zamówić jeśli nic innego nie pomoże. Co do gniazda to kable do niego dolutowałem, samo gniazdo wygląda na sprawne. Kable zostały podłączone zgodnie ze schematem, z resztą inne podłączenie spowodowało by brak grzania lub całkowity brak odczytów z termopary. Przyszła mi jeszcze do gło...
autor: Dudinr1
26 paź 2013, 22:57
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Następną rzeczą po sprawdzeniu napięć (tylko na płytce zasilacza) tych co pisałem wyżej, że są ok, wziąłem się za dokładne sprawdzenie i poprawę lutów na płytkach. Temperatura przedstawiana na LCD reaguje adekwatnie do sytuacji, wątpię jednak aby była to miarodajna wartość. Ponieważ nie mam zasilacz...
autor: Dudinr1
21 paź 2013, 23:42
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Usiałem do kita i będę pisałem na bieżąco to co uda mi się ustalić.

Wyjścia zasilacza:
(poprawcie mnie proszę jeśli popełniłem błąd, COM na mierniku czerwony kabel przykładałem do GND)
VCC +5V
M9V -9,0 lub -9,1
P9V +8,9 lub 9,0
Także napięcia na zasilaczu ok, sprawdzam dalej...
autor: Dudinr1
20 paź 2013, 20:47
Forum: Projekty z bloga
Temat: AVT 987 - problem z temperaturą
Odpowiedzi: 46
Odsłony: 39433

Re: AVT 987 - problem z temperaturą

Dziękuję za sprawdzenie płytki, prosiłem o to ponieważ słyszałem, że w różnych wersjach kitów zdarzały się drobne błędy opisów/schematów/itp..., a niestety brak mi wiedzy aby samodzielnie coś robić, wszystko raczej odtwórcze. Problem z temperaturą teraz jest taki, że stoi cały czas na 25 St.C i nawe...

Strony partnerskie: