Znaleziono 12 wyników

autor: piastek1991
25 sty 2018, 22:07
Forum: Jak to zrobić?
Temat: Arduino->Ethernet->Domoticz tylko po kablu
Odpowiedzi: 1
Odsłony: 2859

Re: Arduino->Ethernet->Domoticz tylko po khablu

Witam trochę czasu minęło ale wątek mnie również interesuje jak rozwiazales kwestie ? Jaka metodę wybrałeś ?
autor: piastek1991
11 maja 2014, 11:49
Forum: Elektronika
Temat: Sterowanie silnikiem 12V
Odpowiedzi: 4
Odsłony: 3418

Re: Sterowanie silnikiem 12V

No to trzeba było by sprawdzić doświadczalnie ale w dokumentacji sprawdzić jaki jest czas przełączania transoptora i porównać z czasem sygnału PWM. Ale PWM w arduino ma częstotliwość ok. 500 Hz czyli okres około 0.002 s a przykładowo czas przełączania transoptora 6n128 to 35 us wiec nie powinno być ...
autor: piastek1991
20 kwie 2014, 16:31
Forum: Elektronika
Temat: Sterowanie silnikiem 12V
Odpowiedzi: 4
Odsłony: 3418

Re: Sterowanie silnikiem 12V

Transoptor powinien też powinien podłączony być przez rezystor do wejścia uK. Nie podłączenie rezystora może spowodować spalenie diody. Reszta wygląda dobrze moim zdaniem. A do czego silnik ? Nie potrzeba ci zmiany kierunku ?
autor: piastek1991
20 kwie 2014, 16:03
Forum: Tutoriale
Temat: Mega 2560 + ArduinoISP + Arduino Pro Mini
Odpowiedzi: 8
Odsłony: 15882

Re: Mega 2560 + ArduinoISP + Arduino Pro Mini

Problem rozwiązał się sam niestety nie wiem co było nie tak. Po kilku próbach i przeinstalowaniu programu udało się dwa razy wgrać problem. Dziękuję za uwagę.
autor: piastek1991
20 kwie 2014, 15:06
Forum: Tutoriale
Temat: Mega 2560 + ArduinoISP + Arduino Pro Mini
Odpowiedzi: 8
Odsłony: 15882

Re: Mega 2560 + ArduinoISP + Arduino Pro Mini

16MHz 5V atmega328p. Podłączenie dobre jest bo próbowałem na wszystkie sposoby już chyba oraz sprawdzałem, port taki sam jak wyświetlony przez menadżer urządzeń.
autor: piastek1991
20 kwie 2014, 13:11
Forum: Tutoriale
Temat: Mega 2560 + ArduinoISP + Arduino Pro Mini
Odpowiedzi: 8
Odsłony: 15882

Re: Mega 2560 + ArduinoISP + Arduino Pro Mini

Tak od tego sposobu zaczynałem jednak też nie pomógł, próby robiłem na trzech różnych komputerach na każdym ten sam błąd. Podłączenie bezpośrednio do Megi nie wymaga ręcznego resetu arduino samo go wykonuje ? Czy wgranie blootloadera powoduję usunięcie starego programu bo u mnie po wgraniu go dioda ...
autor: piastek1991
20 kwie 2014, 12:55
Forum: Problemy
Temat: Problem z tranzystorem i taśmą led.
Odpowiedzi: 3
Odsłony: 3094

Re: Problem z tranzystorem i taśmą led.

Ja od siebie dołożę, że dobrym sposobem jest wykorzystanie tranzystora MOSFET np kanałem typu N. Bardzo proste podłączenie wystarczy sterować napięciem bramki przez sygnał PWM. Tranzystor teoretycznie nie obciąża wyjścia uP ponieważ sterowany jest napięciowo i nie pobiera prądu ( jest on znikomy rzę...
autor: piastek1991
18 kwie 2014, 19:54
Forum: Tutoriale
Temat: Mega 2560 + ArduinoISP + Arduino Pro Mini
Odpowiedzi: 8
Odsłony: 15882

Re: Mega 2560 + ArduinoISP + Arduino Pro Mini

Witam próbuje zaprogramować arduino mini pro jednak otrzymuje błąd "avrdude: stk500_getsync(): not in sync: resp=0x00" próbowałem zaprogramować przy użyciu Arduino Mega 2560 oraz programatorem TTL opartym na układzie PL2303 jednak cały czas otrzymuje powyższy błąd przy próbie wgrania programu , w tr...
autor: piastek1991
5 kwie 2014, 16:21
Forum: Problemy
Temat: Wolne działanie programu przy I2C, jak przyspieszyć ?
Odpowiedzi: 3
Odsłony: 2499

Re: Wolne działanie programu przy I2C, jak przyspieszyć ?

Problem rozwiązałem po przez zastosowanie układu MAXIMA CM7218AIPI ( układ udało mi się zamówić jako darmowe sample, przesyłkę wysyłają kurierem tylko w Polsce kurier miał problem z adresem ponieważ jako organizacje podałem uczelnię a adres prywatny jednak wystarczył telefon do rozwiązania problemu)...
autor: piastek1991
11 mar 2014, 23:52
Forum: Tutoriale
Temat: Programowanie ATmega8A oraz ATmega328P za pomocą Arduino
Odpowiedzi: 153
Odsłony: 424438

Re: Programowanie ATmega8A oraz ATmega328P za pomocą Arduino

Witajcie mam pytanie czy wie ktoś jak rozwiązać problem gdy arduino wyświetla komunikat:

avrdude: stk500_getsync(): not in sync: resp=0x00

bootloader wgrany pomyślnie na atmega164PA jak i atmega8 przy programowaniu przez arduino i USBasp
nie mam pojęcia co jest nie tam możne ktoś pomoże.
autor: piastek1991
1 mar 2014, 02:20
Forum: Problemy
Temat: Wolne działanie programu przy I2C, jak przyspieszyć ?
Odpowiedzi: 3
Odsłony: 2499

Re: Wolne działanie programu przy I2C, jak przyspieszyć ?

Segmenty mam z wspólną anodą a układy dla tego rozwiązania nie udało mi się znaleźć w żadnym sklepie w przystępnej cenie niestety segmenty mam już na gotowej płytce ponieważ wykorzystać chce obudowę która posiadała je już. Chyba że ktoś wie gdzie znaleźć taki układ dla wspólnych anod ? Jeszcze rozwi...
autor: piastek1991
27 lut 2014, 20:56
Forum: Problemy
Temat: Wolne działanie programu przy I2C, jak przyspieszyć ?
Odpowiedzi: 3
Odsłony: 2499

Wolne działanie programu przy I2C, jak przyspieszyć ?

Witam jestem w trakcje realizacji projektu. Natrafiłem na problem z którym nie wiem jak sobie poradzić mianowicie: Wykorzystuje łączność I2C do komunikacji z modułem zegara wyświetlaczem lcd oraz wyświetlaczem &-segmentowym sterowanym przez 2 układy PCF8574AN. Napisałem program sterujący poszczególn...

Strony partnerskie: