problem USBASP v2.0

ODPOWIEDZ
nicolas_wel
Młodszy majsterkowicz
Posty: 3
Rejestracja: 1 lut 2016, 20:48

problem USBASP v2.0

Post autor: nicolas_wel » 1 lut 2016, 21:17

Jako, że to mój pierwszy post witam serdecznie wszystkich Majsterkowo

chcialem pytanie jak zrobic ISP?
Dzis podlsczylem pierwszy raz, oczywiscie zainstalowane
Mam AvrUSBasp 2.0 aby zrobic ISP do Chip AT90USB128X!!

zobacz foto!!!?

prosze pomoc
dzieuje na gora
czekam na odpowiedz
Nie masz wymaganych uprawnień, aby zobaczyć pliki załączone do tego posta.

Co miesiąc do wygrania nagrody o wartości ponad 1600 zł!


nicolas_wel
Młodszy majsterkowicz
Posty: 3
Rejestracja: 1 lut 2016, 20:48

Re: problem USBASP v2.0

Post autor: nicolas_wel » 2 lut 2016, 20:17

??? nic nie odpowiedz
stiven
Złota rączka
Posty: 1629
Rejestracja: 13 maja 2014, 08:47
Lokalizacja: Zielona Góra

Re: problem USBASP v2.0

Post autor: stiven » 2 lut 2016, 21:45

A w tej instrukcji, z której korzystałeś do dodania obsługi AT90USB128X do arduino ide, była podana wersja arduino ide? Ja znalazłem tą instrukcję https://github.com/DynamicPerception/ArduinoAT90USB
i tam jest trochę pokrętnie napisane, ale wychodzi na to, że wersja minimalna to 1.5.2 i nie wyższa niż 1.5.x, czyli na wersjach 1.6.x to już nie będzie działać prawidłowo. Na screenie widać, że pobrałeś wersję 1.6.7, więc jeśli korzystałeś z tej własnie instrukcji, to musisz zainstalować starszą wersję arduino ide do tego.

EDIT
Tam na końcu jest napisane
Please note that at this time, burning bootloaders via the Arduino IDE is not supported.
Bootloader tak naprawdę nie jest potrzebny do wgrywania programów przez usbasp, ale musisz mieć najpierw ustawione prawidłowo fusebity inną metodą, przynajmniej tak jest z atmegą8 i 328, tamtego mikrokontrolera nie znam, ale pewnie też tak jest.
Prawdopodobnie te fusebity są już ustawione i od razu można wgrywać programy. Ale trzeba być pewnym, że tak jest, bo jeśli nie, to wgranie programu może spowodować zablokowanie mikrokontrolera.
nicolas_wel
Młodszy majsterkowicz
Posty: 3
Rejestracja: 1 lut 2016, 20:48

Re: problem USBASP v2.0

Post autor: nicolas_wel » 3 lut 2016, 01:05

witam!
dzieki odpowiedz, tak.... DynamicPerception/ArduinoAT90USB, nie uwazalem programy 1.5.x!!! czy mozna arduino ISP? nie musze USBASP!!?

jak zrobic ustawione prawidłowo fusebity inną metodą, przynajmniej tak jest z atmegą8 i 328? bo troche nie znam arduino! :(

pozdrawiam
dziekuje na gory
ODPOWIEDZ

Strony partnerskie: