Problem w wypaleniem Bootloadera na Attiny2313

Masz problem, z którym nie możesz sobie poradzić? Pisz śmiało!
ODPOWIEDZ
wirniq
Młodszy majsterkowicz
Posty: 4
Rejestracja: 21 gru 2013, 01:02

Problem w wypaleniem Bootloadera na Attiny2313

Post autor: wirniq » 21 gru 2013, 01:10

Witam, to mój pierwszy post :) potrzebuję pomocy, postępując zgodnie z wskazówkami z http://majsterkowo.pl/progamowanie-mikr ... ttiny2313/ dochodzę do momentu kiedy wgrywam przykład ArduinoISP otwiera mi się nowe okienko Arduino z kodem który wgrywam, wszystko idzie zgodnie z planem co potwierdza program, problem zaczyna się gdy chcę wypalić bootloader na attiny, przełączam na obu okienkach na trym programowania Arduino as ISP następnie wybieram płytkę Attiny i klikając wypal bootloader wyskakuje coś takiego: avrdude: stk500_getsync(): not in sync: resp=0x00 to samo dzieje się i ze zworką i bez zworki autoresetu. brak mi pomysłów czemu to nie działa :(

Zapomniał bym dodać mam klona Arduino Leonardo

Co miesiąc do wygrania nagrody o wartości ponad 1600 zł!


wirniq
Młodszy majsterkowicz
Posty: 4
Rejestracja: 21 gru 2013, 01:02

Re: Problem w wypaleniem Bootloadera na Attiny2313

Post autor: wirniq » 22 gru 2013, 00:18

Sprawdziłem połączenia i wszystko jest jak na schemacie, jeśli chodzi o pliki to chyba wszystkie mam skoro w wyborze płytek jest attiny ale też sporo się nakombinowałem bo nie ma nigdzie napisane do którego konkretnie folderu i jakie pliki przekopiować, problem występuje nadal, gdybym miał kłopot z komunikacją z arduino to nie wgrał bym pomyślnie oprogramowania do ISP, czy to raczej błąd pomiędzy attiny a arduino ?

Przenosząc pliki skopiowałem folder tiny i dałem go do folderu hardware, w paczce był też folder tools ale nie przenosiłem go. A i nic nie robiłem z plikami z folderu Wprogram, co mam z nimi zrobić?
Awatar użytkownika
Maxik
Starszy majsterkowicz
Posty: 405
Rejestracja: 6 lip 2012, 18:27
Lokalizacja: Gdańsk
Kontakt:

Re: Problem w wypaleniem Bootloadera na Attiny2313

Post autor: Maxik » 22 gru 2013, 00:42

Błąd jest związany z komunikacją PC z Arduino. Jeśli znasz angielski to przejrzyj ten wpis: http://petervanhoyweghen.wordpress.com/ ... -leonardo/ i zastosuj się do przedstawionych w nim wskazówek.
Awatar użytkownika
rafalzaq
Majsterkowicz
Posty: 180
Rejestracja: 2 maja 2013, 23:57

Re: Problem w wypaleniem Bootloadera na Attiny2313

Post autor: rafalzaq » 22 gru 2013, 14:31

Kiedyś dawno temu nie miałem programatora tylko samo arduino leonardo. W różnych tutorialach było wspomniane że leo jest inne i trzeba zmienić w kodzie pin resetu. Oczywiście nic nie działało. Przeszukałem cały internet. W końcu pojawił się nowy wątek na forum arduino właśnie o tym problemie. No ale żadnego rozwiązania bo "powinno działać". W końcu ktoś przyznał, że faktycznie nie działa i dał rozwiązanie. Rozwiązaniem jest dopisanie nowego programatora do listy (pkt 7. pod powyższym linkiem). Najwyraźniej jeszcze tego nie poprawili.
wirniq
Młodszy majsterkowicz
Posty: 4
Rejestracja: 21 gru 2013, 01:02

Re: Problem w wypaleniem Bootloadera na Attiny2313

Post autor: wirniq » 23 gru 2013, 14:58

Dziękuję wam za pomoc, postepuję zgodnie z instrukcją w folderze hardware tworzę folder leofix a w nim plik tekstowy programmer, wklejam kod z okienka
zapisuję, uruchamiam program ale nie pojawia się nowa opcja w programatorze, co robię źle ? jeszcze według jednego z punktów zmieniłem #define RESET SS
into:
#define RESET 10
wirniq
Młodszy majsterkowicz
Posty: 4
Rejestracja: 21 gru 2013, 01:02

Re: Problem w wypaleniem Bootloadera na Attiny2313

Post autor: wirniq » 23 gru 2013, 20:12

Problem rozwiązany!!! :D w zasadzie wszystko robiłem poprawnie, przeoczyłem tylko jedną linijkę w opisie z linku mianowicie: " Don’t connect them to digital pins 11, 12 and 13: on the leo there is no SPI on these pins." nic tylko siąść i płakać nad własną percepcją... :)
ODPOWIEDZ

Strony partnerskie: