Arduino Uno R3 i modłu Bluetooth BTH-07

Masz problem, z którym nie możesz sobie poradzić? Pisz śmiało!
ODPOWIEDZ
kempa007
Młodszy majsterkowicz
Posty: 4
Rejestracja: 28 mar 2014, 10:14

Arduino Uno R3 i modłu Bluetooth BTH-07

Post autor: kempa007 » 28 mar 2014, 10:21

Witam,

Przede wszystkim witam wszystkich, to mój pierwszy post tutaj :)

Zakupiłem na allegro moduł BTH-07. Jest to układ HC-5 (master/slave) na płytce z wyprowadzonymi 6 pinami, ale mam z nim problem. Podpialem go do Arduino zarówno na plus 3,3V jak i 5V. Za każdym razem działało parowanie, tzn. mój Android jak wpisałem zły klucz informował mnie o tym, gdy wpisałem prawidłowy klucz miałem urządenie HC-5 na liście jako sparowane ale rozłączone. I za Chiny ludowe nie mogę się połączyć do tego modułu, tak aby na stałe świeciłą siędioda sygnalizująca stan modułu. Cały czas mryka z czestotliwością około 2 Hz. Poprzez zwarcie pinów Key i State mogę jedynie sprawić, zę dioda mryga z f = 1Hz....

Będę wdzięczny za pomoc w rozwiązaniu tej sprawy, a przy okazji upewnieniu mnie czy plytke taka musze podlaczac na 3,3 V czy 5 i jak z podlaczeniem pinów do transmisji - czy trzeba korzystać z dzielnika napięcia czy nie, bo w różnych źródłach, róznie ludzie piszą.

Co miesiąc do wygrania nagrody o wartości ponad 1600 zł!


kempa007
Młodszy majsterkowicz
Posty: 4
Rejestracja: 28 mar 2014, 10:14

Re: Arduino Uno R3 i modłu Bluetooth BTH-07

Post autor: kempa007 » 28 mar 2014, 12:06

Dodam jeszcze, ze iPad nie widzi tego modulu tak jak Android :/ Czy to oznacza, ze standard BT HC-05 nie jest kompatybilny z tym urzadzeniem?
kempa007
Młodszy majsterkowicz
Posty: 4
Rejestracja: 28 mar 2014, 10:14

Re: Arduino Uno R3 i modłu Bluetooth BTH-07

Post autor: kempa007 » 28 mar 2014, 14:46

W oczekiwaniu na pomoc zaczalem sam badac sprawe no i zaczalem sie bawic w komendami AT. Wszystko bylo okay do czasu kiedy nie chcialem sprobowac zresetowac ustawien za pomoca AT+ORGL. Teraz nie widze urządzenia nawet z Androida i zadne komendy nie działają, dostaję tylko zwrotkę y z dwoma kropkami na górze :/ Czy ktoś wie jak pomóc w takim wypadku?
kempa007
Młodszy majsterkowicz
Posty: 4
Rejestracja: 28 mar 2014, 10:14

Re: Arduino Uno R3 i modłu Bluetooth BTH-07

Post autor: kempa007 » 14 kwie 2014, 15:39

Witam ponownie,

Okazalo sie, ze przyresetowaniu ustawien tego modulu nie mial on przypisanej klasy urzadzenia BT i dlatego moj stary telefon przestal go wykrywac. Po zapisaniu nowej klasy wszystko wrocilo do stanu poprzedniego i z drugiego telefonu bez problemu sie polaczylem, wiec pewnie byl jakis problem ze standardem BT miedzy telefonem a modulem.

Wracajac do tematu teraz mam taki problem, ze po zainstalowaniu aplikacji Bluetooth Terminal gdy wysylam na przyklad cyfre 0 otrzymuje na terminalu cos w stylu "0 128". Nie sprawdzalem urzadzenia na innej aplikacji, ale chcialbym wysylajac 0 otrzymac na terminalu (serial monitorze) takze 0.
cnc4you
Młodszy majsterkowicz
Posty: 6
Rejestracja: 29 maja 2013, 12:41

Re: Arduino Uno R3 i modłu Bluetooth BTH-07

Post autor: cnc4you » 4 maja 2014, 20:54

Hej
Mam takie małe pytanie. Prawdopodobnie mam podobny problem. Mam dwa moduły HC-05 wszystko działało poprawnie dopóki nie przywróciłem ustawień fabrycznych. Teraz mogę wejść w tryb komend i moduły są wykrywalne przez telefony itp, ale za nic nie mogę się sparować. Chwilę coś się dzieje ale nawet nie woła pinu? Czy wiesz może co może być przyczyną?
ODPOWIEDZ

Strony partnerskie: