nie działa zapis na karcie SD

Masz problem, z którym nie możesz sobie poradzić? Pisz śmiało!
ODPOWIEDZ
szymek261
Młodszy majsterkowicz
Posty: 10
Rejestracja: 21 lut 2014, 23:06

nie działa zapis na karcie SD

Post autor: szymek261 » 1 wrz 2015, 21:31

witam
mam problem z karta sd w arduino mega (i jak w każdym innym arduino leonardo i pro mini)
problem polega na tym ze mam problem z zapisem informacji do pliku
sam plik na karcie sd zostaje stworzony ale nic się nie zapisuje do niego ;/
proszę o pomoc jest to mi potrzebne do pracy naukowej
Gdy coś się zapisze to pełno jest folderów i plików na karcie nie w naszym języku bo jakieś dziwne znaczki

I w programie cardinfo wyskakuje na końcu takie coś

write speed and latency
speed,max,min,avg
KB/Sec,usec,usec,usec
error: write failed
SD errorCode: 0X13,0X0

Co miesiąc do wygrania nagrody o wartości ponad 1600 zł!


Artur997
Majsterkowicz
Posty: 101
Rejestracja: 23 paź 2013, 20:22

Re: nie działa zapis na karcie SD

Post autor: Artur997 » 1 wrz 2015, 22:32

Porada kiepska, ale spróbuję. Proponuję spróbować innej karty. Albo sprawdzić tę kartę np w komputerze.
lolo
Młodszy majsterkowicz
Posty: 17
Rejestracja: 22 sty 2015, 19:31

Re: nie działa zapis na karcie SD

Post autor: lolo » 9 wrz 2015, 22:59

ja chyba miałem podobny kłopot. Okazało się że program nie zamykał pliku. Karta niby była OK ale nic się nie dało zapisać, bo "sesja" była otwarta. Po formacie karty programem SD Formatter 4.0 for SD/SDHC/SDXC pomogło.

Co ciekawe, najpierw Arduino nie widział karty a po formacie tym programem wszystko jest ok.
ODPOWIEDZ

Strony partnerskie: