sim800L EVB Nie loguje się do sieci

Masz problem, z którym nie możesz sobie poradzić? Pisz śmiało!
hugo1415
Młodszy majsterkowicz
Posty: 17
Rejestracja: 24 lis 2017, 21:41

sim800L EVB Nie loguje się do sieci

Post autor: hugo1415 » 24 lis 2017, 21:49

Witam,

Chciałem zacząć jakąś zabawę z używaniem GSM w arduino ale oczywiście poległem przy pierwszych 5 minutach.

Posiadam moduł sim800l na płytce EVB v2.2, RX i TX podłączone do arduino, komunikacja jest, odpowiada na polecenie AT.
Zasilanie najpierw ciągnąłem bezpośrednio z arduino, wyczytałem że może to powodować problemy dlatego podłączyłem pod ładowarkę od telefonu 5v 2a ale wtedy utraciłem kontakt z modułem w sumie nie do końca wiem dlaczego. Po zmostkowaniu mas arduino i ładowarki komunikacja wróciła ale cały czas moduł nie chce zalogować się do sieci. Nie reaguje na inne karty sim, w zasadzie nawet nie reaguje kiedy mu je wyjmuje czy wkładam. Dioda net cały czas mruga dość szybko.

Nadajniki wykrywa chyba poprawnie:
at+cops=?
+COPS: (1,"IDEA Centertel","IDEA","26003"),(1,"26006","26006","26006"),(2,"Era","Era","26002"),(1,"Plus GSM","PLUS","26001"),,(0-4),(0-2)
OK

Karta sim włożona jest raczej prawidłowo, zgodnie z rysunkiem na module, antena jest podłączona do gniazda, prąd ma, nie wiem o co jeszcze może mu chodzić dlatego proszę o jakieś podpowiedzi ;)

Z tego co wyczytałem ta płytka obsługuje logikę 5v dlatego nie używam konwertera.


Eliminacja wszystkiego co może nie działać....nadal nic:
Obrazek

Może się okazać że ma uszkodzony albo błędny wewnętrzy soft ? Chiński simlock czy co?

Co miesiąc do wygrania nagrody o wartości ponad 1600 zł!


mghjaatgkktuejdj
Majsterkowicz
Posty: 134
Rejestracja: 12 lut 2016, 16:35

Re: sim800L EVB Nie loguje się do sieci

Post autor: mghjaatgkktuejdj » 25 lis 2017, 17:24

Zasilanie z ładowarki podłącz z pominięciem płytki stykowej. Podłącz ją bezpośrednio do pinów modułu gsm. Karta sim też może być źle włożona. Pokaż zdjęcie częściowo wsuniętej karty sim.
hugo1415
Młodszy majsterkowicz
Posty: 17
Rejestracja: 24 lis 2017, 21:41

Re: sim800L EVB Nie loguje się do sieci

Post autor: hugo1415 » 25 lis 2017, 17:43

Już wszystko pokazuje, podłączyłem wszystko do akumulatora 12v przez przetwornice o wydajności 3A, na zdjęciu jest MAKSYMALNY pobór jaki moduł osiąga na starcie, później spada do 0.01A.

Obrazek
Obrazek
mghjaatgkktuejdj
Majsterkowicz
Posty: 134
Rejestracja: 12 lut 2016, 16:35

Re: sim800L EVB Nie loguje się do sieci

Post autor: mghjaatgkktuejdj » 25 lis 2017, 18:21

Mam inną wersję sim800l, ale wydaje mi się, że kartę sim włożyłeś poprawnie. Dla testu możesz kartę sim włożyć też inną stroną (od złego włożenia karty sim moduł nie uszkodzi się). Zasilania modułu nie podłączaj razem z miernikiem w obwodzie. Szczególnie ważne jest to wówczas kiedy zasięg sieci jest słaby. Jeżeli masz to podłącz lepszą antenę. Arduino też nie podłączaj. Podłącz tyko moduł gsm i zasilacz. Dzwoniąc na numer modułu zobacz, czy zalogował się on do sieci. Pamiętaj, że karta sim nie może mieć blokady (żądanie wpisania pinu).
hugo1415
Młodszy majsterkowicz
Posty: 17
Rejestracja: 24 lis 2017, 21:41

Re: sim800L EVB Nie loguje się do sieci

Post autor: hugo1415 » 25 lis 2017, 18:39

Wpięty bezpośrednio pod przetwornice, karte najpierw zostawiłem jak jest, pożniej odwróciłem zresetowałem układ podłączyłem. W sumie są tylko dwie możliwości włożenia tej karty. W obu przypadkach dioda miga dość szybko i numer nie odpowiada :/ Karta nie ma pinu

Obrazek
mghjaatgkktuejdj
Majsterkowicz
Posty: 134
Rejestracja: 12 lut 2016, 16:35

Re: sim800L EVB Nie loguje się do sieci

Post autor: mghjaatgkktuejdj » 25 lis 2017, 18:55

Rozumem, że przetwornica na wyjściu daje 5V? Jeżeli tak, to podłącz dodatkowo miernik i sprawdź, czy przy logowaniu modułu do sieci napięcie na jej wyjściu nie spada poniżej 5V.
hugo1415
Młodszy majsterkowicz
Posty: 17
Rejestracja: 24 lis 2017, 21:41

Re: sim800L EVB Nie loguje się do sieci

Post autor: hugo1415 » 25 lis 2017, 18:59

Przetwornica jest ustawiona na dokładnie 5.09V, maksymalne wahnięcie jakie wykazuje miernik to 5,07V. Niżej nie spada
mghjaatgkktuejdj
Majsterkowicz
Posty: 134
Rejestracja: 12 lut 2016, 16:35

Re: sim800L EVB Nie loguje się do sieci

Post autor: mghjaatgkktuejdj » 25 lis 2017, 19:03

To sprawdź jeszcze inną kartę sim.
hugo1415
Młodszy majsterkowicz
Posty: 17
Rejestracja: 24 lis 2017, 21:41

Re: sim800L EVB Nie loguje się do sieci

Post autor: hugo1415 » 25 lis 2017, 19:07

Zmieniłem kartę z Orange na Viking(Play), nadal bez najmniejszego kurna efektu. Napięcie tak samo stabilne. Jest jakieś polecenie AT pokazujące nie wiem ,numer sima czy coś ? Żeby sprawdzić czy on wgl ma jakikolwiek kontakt z kartą
hugo1415
Młodszy majsterkowicz
Posty: 17
Rejestracja: 24 lis 2017, 21:41

Re: sim800L EVB Nie loguje się do sieci

Post autor: hugo1415 » 25 lis 2017, 19:54

Chwilę spróbowałem POROZMAWIAĆ z modułem, rozumiem z tego 50:50, może ktoś mądrzejszy coś wypatrzy podejrzanego:

at
OK

at+cpin?
ERROR

at+cpin
ERROR

at^spic
ERROR

at+creg?
+CREG: 0,0
OK

at+creg=?
+CREG: (0-2)
OK

at+creg=2
OK

at+creg?
+CREG: 2,0
OK

at+creg?
+CREG: 2,0
OK

at+cops?
+COPS: 0
OK

at+cops=?
+COPS: (2,"Era","Era","26002"),(1,"26006","26006","26006"),(1,"Plus GSM","PLUS","26001"),(1,"IDEA Centertel","IDEA","26003"),,(0-4),(0-2)
OK
mghjaatgkktuejdj
Majsterkowicz
Posty: 134
Rejestracja: 12 lut 2016, 16:35

Re: sim800L EVB Nie loguje się do sieci

Post autor: mghjaatgkktuejdj » 25 lis 2017, 19:56

Możesz sprawdzić, czy jesteś w stanie odczytać smsy zapisane na karcie sim. http://www.smssolutions.net/tutorials/gsm/receivesmsat/

Wydaje mi się, że jeszcze zasilanie modułu należy poprawić. Problem w tym module jest taki, że napięcie zasilające z 5V obniżane jest od ok. 4V przez dwie diody. Jest to rozwiązanie najgorsze z możliwych. Dodatkowo Twoja przetwornica sieje. Osobiście wyrzuciłbym te diody i moduł zasilił 4V, ale nie z przetwornicy tylko z ogniwa 18650. Po tej czynności będziesz miał pewność, że zasilanie jest ok.

Ponadto zauważyłem, że moduł nie ma przylutowanego kondensora c6 i rezystora r16. Trzeba by sprawdzić na schemacie w jakim celu zostały one tam umieszczone. Jeżeli nie masz schematu to poproś sprzedawce o takowy.

Te polecenia powyżej pokazują, że moduł nie jest zalogowany do sieci. Być może się cały czas resetuje.
hugo1415
Młodszy majsterkowicz
Posty: 17
Rejestracja: 24 lis 2017, 21:41

Re: sim800L EVB Nie loguje się do sieci

Post autor: hugo1415 » 25 lis 2017, 20:07

Na polecenia AT+CMGR=1 czy z jedynką zerem czy dwójką układ odpowiada ERROR. Także w sumie nie wiem czy nie zna tego polecenia tak samo jak nie zna CPIN czy coś jest nie hallo. Tak zerknąłem na szybko w internet to moduły EVB v2.2 nie mają faktycznie tych dwóch elementów co w sumie jest zastanawiające no ale ludziom jakoś to jednak działa. Nie chciałbym go lutować zmieniać bo w sumie moduł zakupiłem ze 3 dni temu przez internet i mogę go jeszcze oddać jeżeli będzie podejrzenie że to jego wina.

Moment jeszcze wrzuce mu zasilanie faktycznie z ogniwa ale teraz to chyba nic nie da skoro tam są diody obniżające ale raczej go nie popsuję.

Czy jeżeli by się resetował diody nie powinny jakoś nie wiem gasnąć czy coś ?

Ano z ogniwa niestety nie rusza w obecnej konfiguracji

Polecenie AT+CMGL="ALL" także ERROR
mghjaatgkktuejdj
Majsterkowicz
Posty: 134
Rejestracja: 12 lut 2016, 16:35

Re: sim800L EVB Nie loguje się do sieci

Post autor: mghjaatgkktuejdj » 25 lis 2017, 20:35

Ogniwo to możesz podłączyć dopiero, jak wywalisz diody, a w ich miejsce dasz zworkę. Z diodami moduł nie ruszy bo napięcie spadnie do ok. 3V.

Jak wysyłasz polecenie "AT" to moduł zawsze odpowiada "OK" ?
hugo1415
Młodszy majsterkowicz
Posty: 17
Rejestracja: 24 lis 2017, 21:41

Re: sim800L EVB Nie loguje się do sieci

Post autor: hugo1415 » 25 lis 2017, 20:42

No wlasnie sie domyśliłem no ale jak już pisałem nie chce w nim grzebać. Kupiłem ma działać, jak nie działa to oddaje wezmę inny ;). Wysłałem z 30 poleceń AT jedno po drugim szybko, na każde odpowiedział natychmiast OK
mghjaatgkktuejdj
Majsterkowicz
Posty: 134
Rejestracja: 12 lut 2016, 16:35

Re: sim800L EVB Nie loguje się do sieci

Post autor: mghjaatgkktuejdj » 25 lis 2017, 20:56

Jeżeli zawsze odpowiada na AT OK to znaczy, że komunikacja po uart działa prawidłowo. Z tego wniosek, że bez ingerencji w zasilanie chyba nic więcej nie da się zrobić. Jak będziesz kiedyś robił zakupy na aliekspress to zainteresuj się modułem gsm Air200 (za 4$). Jest o nim wątek na elektrodzie i filmik na YouTube.
hugo1415
Młodszy majsterkowicz
Posty: 17
Rejestracja: 24 lis 2017, 21:41

Re: sim800L EVB Nie loguje się do sieci

Post autor: hugo1415 » 25 lis 2017, 21:10

No ok dzięki, zadzwonię w tygodniu do sprzedawcy i zrobię zwrot, mam nadzieję że nie będzie marudził za bardzo. Air200 to ten który mogł pracować autonomicznie, dobrze kojarze? Właśnie jaki kupić, bedę potrzebował sterowania ze 2-3 przekaźnikami i ze 3 czujnikami temperatury. Aira czy ten zwykły czerwony moduł sim800 ? Może ktoś poleci jakiś bardziej sprawdzony ale z obsługą logiki 5v?
mghjaatgkktuejdj
Majsterkowicz
Posty: 134
Rejestracja: 12 lut 2016, 16:35

Re: sim800L EVB Nie loguje się do sieci

Post autor: mghjaatgkktuejdj » 25 lis 2017, 21:42

Posiadam ten czerwony sim800l i on musi być zasilany 4V. Na uart trzeba dać konwerter.

Mam też sim800c z bluetooth. Może on być zasilany z 4V i 5V i ma już wbudowany konwerter. https://www.elektroda.pl/rtvforum/viewt ... highlight=

Air200 zasilany jest 5V i jego większa wersja jest z ch340. Może on działać również bez użycia mikrokontrolera. Do sterowania pinem (przekaźnikiem) na elektrodzie jest gotowy skrypt. Odczyt temperatury będziesz musiał sam napisać.

Jeżeli chcesz moduł bardziej popularny to polecam sim800c, ale ze zdjęcia powyżej.

Mam też kilka m590, m590e i jeden a6, ale ich nie polecam.
hugo1415
Młodszy majsterkowicz
Posty: 17
Rejestracja: 24 lis 2017, 21:41

Re: sim800L EVB Nie loguje się do sieci

Post autor: hugo1415 » 25 lis 2017, 22:11

No wszystko się w teorii zgadza kolego no ale ja mam właśnie EVB i z nim są takie jaja jak berety. Ma przetwornice 3 amperową ma sima bez pinu ma antenę i jest przyslowiowa dupa ;) W sumie skoro mówisz że ma stabilizację może podniose mu napięcie do 6v? Chociaż nie wiem czy to coś zmieni


A ten czerwony moduł ok zasilany jest z 4v to juz lekki problem a uart ma ma 3.3 tak? czy jeszcze niżej?
mghjaatgkktuejdj
Majsterkowicz
Posty: 134
Rejestracja: 12 lut 2016, 16:35

Re: sim800L EVB Nie loguje się do sieci

Post autor: mghjaatgkktuejdj » 25 lis 2017, 23:33

Ten czerwony sim800l uart ma na 2.8V. MrLewerence chyba pisze o jeszcze innej wersji.
Awatar użytkownika
Slawek
Starszy majsterkowicz
Posty: 448
Rejestracja: 29 mar 2015, 15:05

Re: sim800L EVB Nie loguje się do sieci

Post autor: Slawek » 26 lis 2017, 15:42

mghjaatgkktuejdj pisze:
25 lis 2017, 18:21
Mam inną wersję sim800l, ale wydaje mi się, że kartę sim włożyłeś poprawnie. Dla testu możesz kartę sim włożyć też inną stroną (od złego włożenia karty sim moduł nie uszkodzi się). Zasilania modułu nie podłączaj razem z miernikiem w obwodzie. Szczególnie ważne jest to wówczas kiedy zasięg sieci jest słaby. Jeżeli masz to podłącz lepszą antenę. Arduino też nie podłączaj. Podłącz tyko moduł gsm i zasilacz. Dzwoniąc na numer modułu zobacz, czy zalogował się on do sieci. Pamiętaj, że karta sim nie może mieć blokady (żądanie wpisania pinu).
Przecież na zdjęciu jest rysunek jak włożyć kartę, więc jak ma kolega włożyć inaczej ?
mghjaatgkktuejdj
Majsterkowicz
Posty: 134
Rejestracja: 12 lut 2016, 16:35

Re: sim800L EVB Nie loguje się do sieci

Post autor: mghjaatgkktuejdj » 26 lis 2017, 16:53

Rysunek na pcb jest mało istotny, ponieważ Chińczycy mogli zrobić błąd. Wiarygodniejsze jest wytłoczenie wzoru karty sim na metalowej kopercie, które zobaczyłem dopiero po napisaniu postu. Dla jasności napiszę, że karta jest dobrze włożona.
hugo1415
Młodszy majsterkowicz
Posty: 17
Rejestracja: 24 lis 2017, 21:41

Re: sim800L EVB Nie loguje się do sieci

Post autor: hugo1415 » 26 lis 2017, 17:13

Obecnie moduł pracuje w drugim pokoju przy oknie z przetwornicą i baterią 9V, kompletnie NIC. Żadnej rewolucji żadnego efektu. Napisałem już do sprzedawcy co o tym sądzi ale po mojemu ten moduł kompletnie nie widzi sima, nie wiem czy gniazdo ma zimny lut czy o co mu chodzi ale z tego co tutaj koledzy piszecie mając sim bez pinu + prąd o wydajności 2a skokowo to moduł na płytce evb ma zadziałać i koniec. No a nie działa ;) także muszę chyba się ładnie prosić o wymianę przez sprzedawcę. Zależałoby mi na takiej wersji jak EVB teoretycznie mało problemowa, logika 5v, podpinam MA DZIAŁAĆ.
mghjaatgkktuejdj
Majsterkowicz
Posty: 134
Rejestracja: 12 lut 2016, 16:35

Re: sim800L EVB Nie loguje się do sieci

Post autor: mghjaatgkktuejdj » 26 lis 2017, 17:48

Może jeden ze styków nie przylega do karty sim (nie łączy)? Można by je spróbować igłą lub drucikiem lekko podgiąć w stronę karty sim, aby lepiej łączyły. Kartę sim też można przeczyścić.
hugo1415
Młodszy majsterkowicz
Posty: 17
Rejestracja: 24 lis 2017, 21:41

Re: sim800L EVB Nie loguje się do sieci

Post autor: hugo1415 » 26 lis 2017, 18:19

Zdaję się że wpadłeś na dobry trop, dlaczego nie przyjrzałem się wcześniej dokładnie temu gniazdu. Co prawda wszystkie piny wyglądają OK i wszystkie są na równej wysokości sporo wyżej od poziomu "gruntu" także styk muszą mieć bez gadania, ALE miernik wykazał zwarcie między dwoma pinami oznaczonymi na zdjęciu (2 i 4 od prawej) !!!! A karta sim nie jest w tym miejscu zwarta, ma dwa odrębne pola także stawiam że nie powinno tak być prawda ? Niech ktoś powie że prawda i mogę to odesłać w pizdu z czystym sumieniem że to nie moja wina ;)

Obrazek
mghjaatgkktuejdj
Majsterkowicz
Posty: 134
Rejestracja: 12 lut 2016, 16:35

Re: sim800L EVB Nie loguje się do sieci

Post autor: mghjaatgkktuejdj » 26 lis 2017, 18:38

Zaraz sprawdzę w sowich modułach gsm czy mam zwarcie.

EDIT:

W innym modelu niż Twój (sim800c i sim800l) zwarcia na stykach karty sim nie ma, ale w m590 zwarcie już jest. Trzeba by sprawdzić schemat Twojego modułu lub ktoś by to musiał zrobić u siebie.
Ostatnio zmieniony 26 lis 2017, 19:10 przez mghjaatgkktuejdj, łącznie zmieniany 1 raz.
ODPOWIEDZ

Strony partnerskie: