Problem z komunikacją komputera z Arduino Uno

Masz problem, z którym nie możesz sobie poradzić? Pisz śmiało!
ODPOWIEDZ
wogrodnik
Młodszy majsterkowicz
Posty: 3
Rejestracja: 20 lip 2019, 15:35

Problem z komunikacją komputera z Arduino Uno

Post autor: wogrodnik » 20 lip 2019, 16:00

Witam.

Kupiłem Arduino Uno r3 (klon) opisany w taki sposób:
"Nasz moduł zbudowany jest w oparciu o licencje OPEN-SOURCE czyli w 100% kompatybilny z oryginałemi nie jest oparty na CH340 ( taki moduł nie działa na sterownikach ARDUINO )".

Po podłączeniu przez zasilacz do gniazda sieciowego widać, że działa seryjnie wgrany "blink".
Jednakże po podłączeniu do komputera, komputer nie rozpoznaje Arduino.

Pracuję na Win7 x64.
Pobrałem sterowniki z oficjalnej strony arduino, plik: "Windows ZIP file for non admin install".
Sterowniki zainstalowałem ręcznie z menadżera urządzeń ("dodaj starszy sprzęt") i na liście portów "COM i LPT" widnieje teraz "Arduino UNO (COM5)" z żółtym trójkątem. We właściwościach tego urządzenia w sekcji "stan urządzenia" jest napisane:"Nie można uruchomić tego urządzenia. (Kod 10)".

Po każdorazowym podłączeniu usb do komputera, ten "rozpoznaje" urządzenie jako "unknown device" (na liście "uniwersalnej magistrali szeregowej") komunikując przy tym (we właściwościach): "System Windows ustalił, że oprogramowanie sterownika dla tego urządzenia jest aktualne."

W trakcie resetu komputera z podłączonym cały czas Arduino podczas niektórych etapów uruchamiania miga dioda "ON" (oraz zintegrowana L) na Arduino aczkolwiek po załadowaniu systemu na płytce nic już nie świeci.

Widzę, obserwując fora, że to nie jest rzadki problem jednakże czytam cały czas na różnych forach i nie znajduję rozwiązania mojego problemu.

Czy ktoś z Was ma pomysł co z tym fantem należy zrobić?

Jako nowy użytkownik forum nie mam możliwości wstawiania zdjęć ani linków.

Pozdrawiam

Co miesiąc do wygrania nagrody o wartości ponad 1600 zł!


MrLewerence
Majsterkowicz
Posty: 67
Rejestracja: 12 paź 2013, 20:48
Lokalizacja: ---

Re: Problem z komunikacją komputera z Arduino Uno

Post autor: MrLewerence » 20 lip 2019, 17:05

Zainstaluj normalnie Arduino IDE wraz ze sterownikami. żadne non admin
wogrodnik
Młodszy majsterkowicz
Posty: 3
Rejestracja: 20 lip 2019, 15:35

Re: Problem z komunikacją komputera z Arduino Uno

Post autor: wogrodnik » 20 lip 2019, 23:24

MrLewerence dzięki za odpowiedź.

Usunąłem z komputera wcześniejsze pliki związane z Arduino i wyczyściłem rejestry (CCleaner).
Zainstalowałem "normalne" Arduino IDE zgadzając się oczywiście na sterowniki.

Niestety nic to nie dało.

Nadal podczas podłączania kabla do komputera przez chwilę miga dioda sygnalizująca zasilanie po czym gaśnie a windows informuje, że nie rozpoznano urządzenia USB.

W menadżerze urządzeni znów* pojawia się "KOD 10".
*znów ponieważ przed zainstalowaniem "normalnego" Arduino IDE odinstalowałem wcześniej wgrane sterowniki.

W dalszym ciągu proszę o rady.
Awatar użytkownika
Marhef
Złota rączka
Posty: 1157
Rejestracja: 18 lis 2011, 02:18

Re: Problem z komunikacją komputera z Arduino Uno

Post autor: Marhef » 22 lip 2019, 07:18

Pokaż zdjęcie tej swojej płytki.
Albo napisz, jaki masz układ scalony obok gniazda USB (tam powinien być CH340 albo ATMEGA16u2), bo to może być problem ze sterownikami.
Możesz też użyć innego, lepszego kabla USB. Kilka lat temu były duże problemy z kablami dodawanymi do Arduino.
wogrodnik
Młodszy majsterkowicz
Posty: 3
Rejestracja: 20 lip 2019, 15:35

Re: Problem z komunikacją komputera z Arduino Uno

Post autor: wogrodnik » 22 lip 2019, 17:28

jako "nowy" nie mam możliwości wstawiania zdjęć.
Problem udało się rozwiązać, Marhef trafiłeś z diagnozą:)

Może komuś się w przyszłości przyda:
PRZEWÓD USB DOŁĄCZONY DO PŁYTKI BYŁ USZKODZONY POMIMO JAKICHKOLWIEK WIDOCZNYCH WAD.
Nie był w żadnym miejscu przycięty, mocno zagięty a wtyczki były prawidłowo połączone kablem. Izolacja również piękna.
Pomimo ładnie wyglądającego kabla w razie podobnego problemu polecam przetestować układ na kablu, który został już przez kogoś sprawdzony!

Temat można zamknąć.

Pozdrawiam.
Awatar użytkownika
Marhef
Złota rączka
Posty: 1157
Rejestracja: 18 lis 2011, 02:18

Re: Problem z komunikacją komputera z Arduino Uno

Post autor: Marhef » 23 lip 2019, 09:02

wogrodnik pisze:
22 lip 2019, 17:28
jako "nowy" nie mam możliwości wstawiania zdjęć.
Jako załącznik też nie?! Kiedyś można było. Wiem, że nie można linków dodawać, ale o niemożliwości dodania załącznika nie słyszałem.

Cieszę się, że udało się rozwiązać problem.
ODPOWIEDZ

Strony partnerskie: