Raspberry łączenie z wifi podczas uruchamiania

Masz problem, z którym nie możesz sobie poradzić? Pisz śmiało!
ODPOWIEDZ
sebo
Młodszy majsterkowicz
Posty: 6
Rejestracja: 9 sty 2016, 05:25

Raspberry łączenie z wifi podczas uruchamiania

Post autor: sebo » 16 lip 2017, 00:49

Mam problem z prawidłowym skonfigurowaniem interfejsu wlan0 aby automatycznie łączył się z wifi podczas bootowania. W tej chwili po uruchomieniu RPI nie łączy się z siecią wifi, ale wystarczy choć na chwilę wpiąć kabel sieci Ethernet do przewodowej karty sieciowej, a po chwili rpi łączy się z wifi.
Może ktoś z Was miał podobny problem i zna rozwiązanie tego problemu ?
Dodam jeszcze, że dodałem do pliku /etc/rc.local wpis:
Ifup wlan0

To też się nie sprawdziło.


Moja konfiguracja:
Plik /etc/network/interfaces

#auto wlan0
allow-hotplug wlan0
iface wlan0 inet static
address ********
netmask **********
gateway **********
dns-nameservers ********
wpa-passphrase *********
wpa-ssid **********
wpa-scan-ssid 1
metric 1

auto eth0
allow-hotplug eth0
iface eth0 inet static
address ***********
netmask ************
gateway ************
dns-nameservers *******

Co miesiąc do wygrania nagrody o wartości ponad 1600 zł!


kaczakat
Młodszy majsterkowicz
Posty: 25
Rejestracja: 8 wrz 2017, 15:01

Re: Raspberry łączenie z wifi podczas uruchamiania

Post autor: kaczakat » 3 lip 2018, 11:50

A do czego jest ta kratka: #auto wlan0 ? Na rasb się nie znam, ale zainstalowałem zgodnie z tutorialem z Forbota i łączy się wifi automatycznie. No i wstaw coś zamiast gwiazdek.
Edit: tu jest o tworzeniu pliku z ssid i hasłem https://forbot.pl/blog/kurs-raspberry-p ... ec-id21051 .
ODPOWIEDZ

Strony partnerskie: