Problem z silnikiem krokowym do CNC SHIELD Arduino

Masz problem, z którym nie możesz sobie poradzić? Pisz śmiało!
ODPOWIEDZ
Riki12344123
Młodszy majsterkowicz
Posty: 2
Rejestracja: 25 lip 2019, 08:36

Problem z silnikiem krokowym do CNC SHIELD Arduino

Post autor: Riki12344123 » 25 lip 2019, 10:08

Witam,

posiadam chińską maszynę CNC 6040. Przerabiam ją na soft GRBL ponieważ tak mi wygodniej.
Maszyna posiada silniki krokowe 3A, które działają na 24V, sprawdziłem indukcję cewek i wynosi 0,8Ohm, więcej informacji niestety nie mam bo silniki nie mają nalepek z nazwami itd. Podłączyłem je do CNC shieldu położonego na Arduino UNO z wgranym GRBL wersją 0.9.
StepStick to TB67S109 : max 4A, potencjomatr ustawiony na 1,5V co daje wartość wyjściową 3A (max curr = Vref * 2 ).
Podłączone zasilanie oczywiście 24V, ustawienie kroków to 1/8, a silnik chodzi tak (ciche cykanie, piszczenie, bardzo małe kroki, tak jakby chciał a nie mógł) - nie mogę wstawić linku z nagraniem niestety.

Nie wiem gdzie jest problem :( Na 1/2 i 1/4 kroku chodzi dobrze ale słychać zatrzymanie przy każdym kroku - cały drga.
Ustawienia oprogramowania są na załączonym zdjęciu. Wygląda tak jakby kondensator nie dawał rady wyczyścić szumów.
Co o tym myślicie bo siedzę już dwa dni i nie mam pomysłu ? Może coś w GRBLu da się zmienić jeszcze?
Nie masz wymaganych uprawnień, aby zobaczyć pliki załączone do tego posta.

Co miesiąc do wygrania nagrody o wartości ponad 1600 zł!


Riki12344123
Młodszy majsterkowicz
Posty: 2
Rejestracja: 25 lip 2019, 08:36

Re: Problem z silnikiem krokowym do CNC SHIELD Arduino

Post autor: Riki12344123 » 25 lip 2019, 10:09

OSTRZEŻENIE ZA OMIJANIE BLOKADY ANTYSPAMOWEJ
ODPOWIEDZ

Strony partnerskie: